
Podłączenie odbiornika RD448 do komputera PC. 

Niniejszy dokument, w formie pytań i odpowiedzi,  wyjaśnia czym jest odbiornik RD448, jak podłączyć go do 
komputera PC oraz jak zainstalować i w jaki sposób używać oprogramowania o nazwie „RD reader” służą-
cego do komunikacji pomiędzy RD448 a komputerem PC. 
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1. Co to jest odbiornik RD448 ? 

Odbiornik RD448 stosowany jest w systemach zdalnego sterowania. Posiada dużą pamięć pilotów - może 
współpracować nawet z 448 pilotami Elmes. Posiada również pamięć ostatnich 6144 zdarzeń. W momencie 
naciśnięcia przycisku pilota do tej pamięci wpisywane są: aktualna data i czas, numer użytego pilota (0..447) 
oraz przycisku (0..1). Zawartość tej pamięci może być wczytana do komputera PC. 

2. Jak podłączyć RD448 z komputerem PC ? 

Wczytywanie do komputera PC zdarzeń zapisanych w pamięci odbiornika RD448 odbywa się przez złącze 
szeregowe RS232 za pomocą kabla–konwertera napięć RS232(+12/-12V)<->TTL (0/5V). Jest to popularny i 
łatwo dostępny kabel, który posiada wbudowany układ MAX232 do konwersji napięć występujących na złą-
czu szeregowym RS232 komputera do poziomów TTL występujących w odbiorniku RD448. W kabel taki 
można się zaopatrzyć w firmie Elmes Elektronik. 
Jeśli komputer nie jest wyposażony w port RS232, należy użyć dodatkowego interfejsu USB <-> RS232. 

3. Jakiego programu użyć do komunikacji RD448 z komputerem ? 

Do komunikacji z odbiornikiem RD448 służy aplikacja o nazwie: "RD reader", dostępna nieodpłatnie na stro-
nie firmowej WWW.elmes.pl . Aplikacja ta wczytuje z pamięci RD448 wszystkie nowe zdarzenia i dołącza je 
do pliku bazy danych Access (*.mdb). Umożliwia także przeglądanie zdarzeń w porządku chronologicznym. 
Aplikacja pracuje wyłącznie w środowisku „Windows”. 
 

4. Jak zainstalować aplikację "RD reader" ? 

Domyślnym katalogiem, w którym instaluje się oprogramowanie, jest: „C:\Program Files\RDreader”. Po zain-
stalowaniu programu RDreader, należy utworzyć nowe źródło danych ODBC o nazwie RDreader. W tym ce-
lu należy wykonać następujące kroki: 

a) w „Panelu Sterowania” uruchomić „Narzędzia Administracyjne” -> ”Źródła danych ODBC”; 
Uwaga ! W systemie Windows 7 64-bit należy, zamiast powyższego kroku, uruchomić aplikację: 

c:\Windows\SysWOW64\odbcad32.exe 

http://www.elmes.pl/


b) odkryć zakładkę „Systemowe DNS” (lub „DSN użytkownika”), kliknąć przycisk „Dodaj…”; 
 

 
 

c) wybrać z listy pozycję „Microsoft Access Driver (*.mdb)”; 
 

 
 
Uwaga ! Jeśli nie możemy znaleźć na liście pozycji: „Microsoft Access Driver (*.mdb)”, oznacza to, że 
nasz system operacyjny jest 64-bitowy. W takim przypadku należy wrócić do pkt 4a), i uruchomić pro-
gram „odbcad32.exe” znajdujący się w katalogu „c:\Windows\SysWOW64”. 



d) w pole „Nazwa źródła danych” wpisać „RDreader” (bez cudzysłowów) i przycisnąć OK; 
 

 
 

e) Na liście systemowych źródeł danych pojawi się nowa pozycja: 
 

 
 

f) zakończyć procedurę klikając OK. 
g) teraz dopiero można uruchomić sam program klikając na plik c:\Program Files\RDreader\Rd6.exe. 

 

5. Jak używać aplikacji "RD reader" ? 

Pierwszym krokiem po uruchomieniu aplikacji "RD reader" jest wybór portu szeregowego COM do komuni-
kacji z odbiornikiem RD448 (menu Tools->Option). Jeśli komputer nie jest wyposażony w port RS232, nale-
ży użyć przejściówki USB <-> RS232 i zainstalować dostarczane z nią drivery. Wówczas w systemie pojawi 
się nowy port COM, np.: COM7. Należy go wybrać w menu Tools->Option. Jeśli jednak, z jakichś powodów, 
utworzy się port o numerze większym niż 9, np. COM10, należy zmienić mu numer na któryś z zakresu 1..9: 
Panel Sterowania -> System -> Manager Urządzeń -> Porty (COM i LPT) -> Port komunikacyjny COMx -> 
Ustawienia portu -> Ustawienia zaawansowane -> Numer portu. 
 
Następnie wybieramy z menu File->Open Database  bazę danych, do której zapisane zostaną zdarzenia 
wczytane z odbiornika RD448. Jeśli chcemy utworzyć nową bazę danych, wybieramy z menu File -> 
New Database. To ostatnie polecenie tak naprawdę kopiuje wzorcową bazę danych o nazwie „templa-



te.mdb” pod nową nazwę podaną przez użytkownika. Aby polecenie się wykonało, w katalogu w którym two-
rzymy nową bazę danych musi znajdować się plik „template.mdb”. Należy go skopiować z katalogu, w któ-
rym zainstalował się program „RDreader”. 
Dopiero teraz możemy wykonać operację wczytania zdarzeń z odbiornika RD448: menu Tools->Read 
events lub klikając ikonkę na pasku zadań (Toolbar). W tym momencie program rozpocznie procedurę wczy-
tywania wszystkich nowych zdarzeń z pamięci odbiornika RD448 i zapisywania ich do bazy danych. Wczy-
tanie całej pamięci może trwać nawet ponad 1 minutę. Po zakończeniu ukaże się informacja, ile zdarzeń zo-
stało wczytanych. W oknie głównym programu można przejrzeć wczytane zdarzenia. 

6. Czy po wczytaniu zdarzeń z pamięci odbiornika RD448 jest ona zerowana ? 

Po wczytaniu zdarzeń z pamięci odbiornika RD448 i zapisaniu ich do bazy danych pamięć odbiornika nie 
jest zerowana. Dlaczego więc kolejne czytanie tej pamięci nie wczytuje już żadnych zdarzeń ? 
Otóż aplikacja "RD reader" wczytuje z odbiornika RD448 do pliku bazy danych programu Microsoft Access 
tylko nowe zdarzenia, czyli takie, które nie były wczytane wcześniej. Jeśli utworzyliśmy nową bazę danych, 
aplikacja wczyta wszystkie zdarzenia z pamięci odbiornika RD448 i zapisze je do nowo utworzonej bazy da-
nych. Przy kolejnym wywołaniu komendy wczytywnia zdarzeń, aplikacja potraktuje ostatnie, zapisane do 
bazy danych zdarzenie jako wzorzec do przeszukiwania pamięci zdarzeń odbiornika RD448. Wszystkie te 
zdarzenia, które są młodsze niż zdarzenie ze wzorca, czyli miały miejsce później, zostaną dopisane do bazy 
danych. Pozostałe, czyli starsze, nie. 
Jeśli więc usuniemy pewną ilość ostatnich zdarzeń z bazy danych (do 6144) - np. celowo, albo w wyniku ja-
kiegoś błędu, to przy kolejnym czytaniu pamięci RD448 zdarzenia te zostaną ponownie wczytane i dodane 
do bazy danych. 

7. Jak dokładny jest zegar odbiornika RD448 i czy można go przestawić ? 

Zegar w odbiorniku RD448 jest stabilizowany kwarcem i w ogóle nie da się go przestawić, gdyż nie jest to 
potrzebne. Odbiornik odlicza czas, ale nie jest to prawdziwy zegar zliczający lata, miesiące, dni itd. Jest to 
tylko prosty licznik sekund.  W momencie użycia pilota, stan tego licznika oraz numer użytego pilota są reje-
strowane w pamięci zdarzeń. Jak więc późnij w bazie danych znajdzie się prawdziwa data i czas naciśnięcia 
pilota ? Bo w chwili czytania zdarzeń z pamięci odbiornika RD448 następuje synchronizacja zegara kompu-
tera z licznikiem odbiornika RD448. Pozwala to wyliczyć "prawdziwą" datę i czas wystąpienia zdarzenia (rok-
miesiąc-dzień i godzina:minuta:sekunda)  i w takiej postaci zapisanie do bazy danych. 
 
Zegar odbiornika RD448 posiada zabezpieczenie na wypadek braku zasilania. Z chwilą wyłączenia prądu 
jest przepisywany do pamięci nieulotnej, skąd jest odtwarzany po powrocie zasilania. Zabezpiecza go to 
przed wyzerowanie w takich momentach, ale nie przed zatrzymaniem na czas braku prądu. Żeby się przed 
tym zabezpieczyć, należy zastosować awaryjne zasilanie akumulatorowe. 
Zegar ma też inne, drobne ograniczenie - po około miesiącu przepełnia się. Ale konsekwencje tego są prak-
tycznie żadne: odstęp czasu pomiędzy dwoma, kolejnymi zdarzeniami zapisywanymi do pamięci nie może 
przekraczać miesiąca. W typowej aplikacji, gdzie codziennie przynajmniej jedna osoba naciśnie pilota, nie 
ma to znaczenia. 

8. Jak można wykorzystać dane odczytane z odbiornika RD448 ? 

Aplikacja "RD reader" tworzy plik bazy danych w formacie Microsoft Access (rozszerzenie *.mdb). Każdy 
program czytający takie pliki, np.: Microsoft Access®, Lotus Approach® czy bezpłatny Base z pakietu Open 
Office®, umożliwia tworzenie zaawansowanych zapytań i raportów. Zakres możliwych zastosowań odbiorni-
ka RD448 i takiej bazy danych jest ograniczony tylko wyobraźnią użytkownika. 

9. Jaka jest struktura bazy danych utworzonej przez program "RD reader" ? 

Polecenie utworzenia nowej bazy danych programu "RD reader" (menu File->New Database) tworzy nową 
bazę danych przez przekopiowanie pliku template.mdb znajdującego się w danym katalogu, pod nową na-
zwę podaną przez użytkownika. Plus tego rozwiązania jest taki, że użytkownik może rozbudować plik tem-
plate.mdb o dodatkowe tabele, zapytania i raporty. 
Późnij każda, utworzona poleceniem File->New Database  baza danych będzie już zawierać te nowe skład-
niki. Należy tylko pamiętać o utworzeniu kopii zapasowej tego pliku na wypadek jego uszkodzenia lub takie-
go zmodyfikowania, że przestanie być czytelny dla programu "RD reader". 
 
Baza danych template.mdb zawiera dwie istotne tabele, których struktur nie wolno zmieniać. Są to: 



a) tabela "EVENTS", która przechowuje zdarzenia wczytywane z odbiornika RD448. Jest to najistotniejsza 
część bazy danych. 
b) tabela "USERS", która przechowuje imiona i nazwiska użytkowników i przypisanych im numerów pilotów. 
Ta tabela jest wykorzystywana przez program "RD reader" do wyświetlania imion i nazwisk użytkowników. 
Jest też użyta do utworzenia przykładowego raportu i kwerendy. 
 
Tabela "EVENTS" zawiera następujące pola: 
INDEX - klucz tej tabeli, pole typu autonumeracja. To pole zawiera numer zdarzenia. Jeśli w two-

rzonych zapytaniach chcemy uzyskać kolejność chronologiczną, powinniśmy zdarzenia 
sortować po tym polu; 

TIMER - "uchwycony" w chwili zdarzenia wewnętrzny zegar odbiornika RD448, 
DATE - data i czas zdarzenia obliczone w chwili wczytywania zdarzeń, 
USER_NO - numer użytego pilota. Ten numer pokazuje się na wyświetlaczu odbiornika RD448 w mo-

mencie naciśnięcia pilota. 
BUTTON - numer użytego przycisku pilota. 
 
Tabela "USERS" zawiera następujące pola: 
INDEX - klucz tej tabeli, pole typu autonumeracja. 
NAME - imię i nazwisko użytkownika, 
USER_NO - numer pilota tego użytkownika, 
DATE_START - od kiedy dany użytkownik używa danego pilota, 
DATE_STOP - kiedy skończył używać danego pilota. 
 
Przeznaczenie większości pól jest chyba jasne. Dwa ostatnie pola tabeli USERS wymagają jednak wyja-
śnienia. Wyobraźmy sobie duży parking, z którego w styczniu i lutym korzystał Jan Kowalski. Miał on pilota 
nr 5. Przestał jednak płacić, w dodatku nie zwrócił pilota. Obsługa parkingu usunęła więc pilota nr 5 z pa-
mięci odbiornika RD448, i wprowadziła w to miejsce nowego, którego otrzymał Jerzy Wiśniewski, nowy 
użytkownik parkingu. Żeby na raportach i w programie "RD reader" rozróżnić obu tych panów, w tabeli 
USERS wprowadzono właśnie pola DATE_START i DATE_STOP. Proszę pamiętać, aby aktualnemu użyt-
kownikowi nie zostawiać pustego pola DATE_STOP, tylko wpisać jakąś przyszłą datę np. 2019-12-31. W 
przeciwnym razie jego nazwisko nie pojawi się on na ekranie w programie "RD reader". 
 
Baza danych template.mdb, oprócz wspomnianych tabel, zawiera jedno, przykładowe zapytanie (kwerendę, 
ang. Query) o nazwie "Events" oraz oparty o nią raport. Oba wykorzystują pola DATE_START i DA-
TE_STOP. Raport, zbudowany w oparciu o tę kwerendę, zawiera zestawienie wszystkich zdarzeń pogrupo-
wanych według użytkowników. 
Uwaga: 
 1. Kwerendę "Events" można modyfikować, ale tylko w edytorze SQL. Próba modyfikacji w edytorze 
graficznym kończy się jej uszkodzeniem. 
 2. Tabela "USERS" zawiera kilka przykładowych wpisów. Znajdą się one w każdej, nowo utworzonej 
bazie danych. Można je edytować lub po prostu usunąć. 

10. Czym otworzyć bazę danych utworzoną przez program "RD reader" ? 

Do otwarcia baz danych utworzonych przez program "RD reader" nadają się wszystkie programy "czytające" 
pliki o rozszerzeniu *.mdb - czyli formatu Microsoft Access. Najbardziej oczywiste wydaje się zastosowanie 
programu "Microsoft Access®", który posiada największe możliwości. Ale dobrze sobie z tym radzi również 
"Lotus Approach®", a także "Base®" z bezpłatnego pakietu "Open Office®". W katalogu, w którym instalo-
wany jest "RD reader", znajduje się plik "parking.odb" utworzony właśnie w programie "Base". Jest on po-
wiązany z przykładową bazą danych o nazwie: "parking.mdb", która zwiera kilkadziesiąt zdarzeń i paru 
użytkowników. Plik "parking.odb" zawiera przykładowe zapytanie i raport, w którym zdarzenia pogrupowane 
są według użytkowników. 
Plik "parking.odb" może służyć za punkt wyjścia do tworzenia bardziej skomplikowanych raportów. W tym 
celu najprościej przekopiować go pod inną nazwą, a po otwarciu zmienić mu "powiązanie" do właściwego 
pliku bazy danych utorzonego wcześniej w programie "RD reader" - menu Edit->Database->Properties (w 
wersji polskiej: Edycja->Baza Danych->Właściwości). 



11. Jak często odczytywać zdarzenia z odbiornika RD448 ? 

Częstotliwość odczytywania zdarzeń z pamięci RD448 zależy od ilości używanych w systemie pilotów. Jeśli 
zakładamy dwukrotne użycie każdego pilota dziennie, a jest tych pilotów tylko 10, pamięć 6144 zdarzeń 
przepełni się po ponad 300 dniach. Przy 448 pilotach, już po około 6 dniach. 


